Аппаратные и программные требования

May 11, 2009

Для версии 5

Системные требования

  • PHP 7.0 со следующими расширениями
    • pdo
    • pdo_pgsql
    • simplexml
    • json
    • curl
    • mbstring
    • imap
    • ionCube PHP Loader
  • Apache 2 или Nginx
  • PostgreSQL 9.3+

Установка возможна на любую операционную систему, включая Windows, Linux, MacOS. Рекомендуемая ОС для установки - Ubuntu Server.

Рекомендуемые аппаратные требования

Ориентировочные требования при одновременной работе 5 пользователей с таблицами до 100 тыс строк:

  • Оперативная память: 512+ МБ
  • Свободное место на жестком диске: 10+ ГБ
  • Частота процессора: 1+ ГГц

Ориентировочные требования при одновременной работе 5 пользователей с таблицами до 1 млн строк:

  • Оперативная память: 2+ ГБ
  • Свободное место на жестком диске: 30+ ГБ
  • Частота процессора: 1+ ГГц x 2

Для версии 4

Аппаратные требования

Серверная часть

  • Оперативная память: 512 МБ
  • Свободное место на жестком диске: 150 МБ + память для роста БД
  • Частота процессора: 1 ГГц

Примечание: этим требованиям удовлетворяет обычный компьютер. В качестве сервера также может быть использован виртуальный хостинг.

Клиентская часть

  • Оперативная память: 256 МБ
  • Свободное место на жестком диске: 200 МБ
  • Частота процессора: 500 МГц

Примечание: в качестве клиентских рабочих мест может быть использован любой компьютер, ноутбук или мобильное устройство, на котором запускается Интернет-браузер с поддержкой Ajax.

Программные требования

Серверная часть

Для работы системы требуются следующие компоненты

  • Поддерживаемые операционные системы: Windows, Mac OS, Linux
  • Web сервер Apache 2.0.55+
  • PHP 5.2.6 – 5.4
  • PHP должен содержать следующие модули
    • PDO для pgsql
    • simplexml
    • json 1.2.1+
    • curl
    • mbstring
    • ionCube PHP Loader
  • В PHP должны быть установлены следующие параметры
    • Отключены «магические кавычки» (magic_quotes_gpc)
  • СУБД Postgres SQL ver 8.3
  • Утилита pgAdmin III ver 1.8 для удобства администрирования базы данных

Примечание: В дистрибутив для Windows включены все перечисленные компоненты.

Клиентская часть

На клиентском рабочем месте требуется только наличие браузера с поддержкой Ajax. Поддерживаются следующие браузеры

  • Firefox 2.0+
  • Google Chrome
  • Opera 9.52+
  • Safari
  • Internet Explorer 8+

Поддерживаемые операционные системы: Windows, Mac OS, Linux.

Примечание: Рекомендуется использовать браузеры Mozilla Firefox, Google Chrome и Safari.